trouble downloading data from garmin etrex venture serial version

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

trouble downloading data from garmin etrex venture serial version

John Lips
I'm using sabayon linux x86_64 with gpsbabel 1.4.4.  My gps is an older garmin
etrex venture serial (not usb).  I have the serial data format set to
garmin in the gps settings.

I've tried with and without the garmin_gps kernel module.  With the
module, I get the following in dmesg:

[ 4093.157294] usbcore: registered new interface driver garmin_gps
[ 4093.157410] usbserial: USB Serial support registered for Garmin GPS
usb/tty
[ 4113.840127] usb 2-2: new full-speed USB device number 2 using
uhci_hcd
[ 4114.007069] usb 2-2: New USB device found, idVendor=0557,
idProduct=2008
[ 4114.007078] usb 2-2: New USB device strings: Mfr=1, Product=2,
SerialNumber=0
[ 4114.007097] usb 2-2: Product: USB-Serial Controller D
[ 4114.007103] usb 2-2: Manufacturer: Prolific Technology Inc.
[ 4114.009473] pl2303 2-2:1.0: pl2303 converter detected
[ 4114.021681] usb 2-2: pl2303 converter now attached to ttyUSB0

As you can see I am also using a serial to usb converter for which I
have built the driver into the kernel:
 
 $ zgrep 2303 /proc/config.gz
 CONFIG_USB_SERIAL_PL2303=y

[    1.769551] usbcore: registered new interface driver pl2303
[    1.771672] usbserial: USB Serial support registered for pl2303

I've read the info regarding troubles garmin gps's at:
http://www.gpsbabel.org/os/Linux_Hotplug.html

But after looking at that page again maybe that info is only relevant to
usb units.

The output I'm seeing with and without garmin_gps:

$ sudo gpsbabel -D9 -w -i garmin -f /dev/ttyUSB0 -o gpx -F waypoints.wpt.gpx
Password:
GPSBabel Version: 1.4.4
Tx Data:10 fe 00 02 10 03 : ...(PRDREQ  )
[ERROR] GPS_Packet_Read: Timeout.  No data received.
GARMIN:Can't init /dev/ttyUSB0

I've also tried it as a normal user and that user is in the uucp group.

$ ls /dev/ttyUSB0
crw-rw---- 1 root uucp 188, 0 2014-07-08 10:37 /dev/ttyUSB0

It looks like I once had this working in a linux OS using gpsbabel in
June of 2011 (based on memory and a wiki entry), but what distro and
what version of gpsbabel I cannot recall.

Any help would be greatly appreciated.

John


------------------------------------------------------------------------------
Open source business process management suite built on Java and Eclipse
Turn processes into business applications with Bonita BPM Community Edition
Quickly connect people, data, and systems into organized workflows
Winner of BOSSIE, CODIE, OW2 and Gartner awards
http://p.sf.net/sfu/Bonitasoft
_______________________________________________
Gpsbabel-misc mailing list http://www.gpsbabel.org
[hidden email]
To unsubscribe, change list options, or see archives, visit:
https://lists.sourceforge.net/lists/listinfo/gpsbabel-misc