OS not supported

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

OS not supported

Ray J 1216
Hi:
 
I have a Delorme PN-30 and there may be corruption in the waypoints list or some other problem in the waypoints.  Topo 8 software will no longer access the list and display the contents.  Delorme support was unable to help.
 
I found your software.  Trying to use it to capture as many of my recently added waypoints as possible.  Just downloaded the latest (1.5.1) on my Windows Vista laptop.  When running, here's what happens (both from GUI and command line):
 
gpsbabel -w -i delbin -f usb: -o gpx -F C:/Users/Ray admin/Documents/waypoints20140718.gpx

delbin: OS not supported


Error running gpsbabel: Process exited unsuccessfully with code 1

 

Note:  I tried adding in the debug command and it didn't add anything interesting.

 

I get the same OS not supported message, whether trying for waypoints (the problem area) or tracks or routes, which works fine with Topo 8.  So, I think there's something simple or fundamental that's wrong.  Any ideas?

 

Note:  I've tried various combinations of Topo 8 open or closed and disconnecting other USB devices.  Can't find a combination that  works. 

 

Regards,

 

RayJ


------------------------------------------------------------------------------
Want fast and easy access to all the code in your enterprise? Index and
search up to 200,000 lines of code with a free copy of Black Duck
Code Sight - the same software that powers the world's largest code
search on Ohloh, the Black Duck Open Hub! Try it now.
http://p.sf.net/sfu/bds
_______________________________________________
Gpsbabel-misc mailing list http://www.gpsbabel.org
[hidden email]
To unsubscribe, change list options, or see archives, visit:
https://lists.sourceforge.net/lists/listinfo/gpsbabel-misc
Reply | Threaded
Open this post in threaded view
|

Re: OS not supported

tsteven4-2
The relevant GPSBabel code is
#if !(HAVE_WDK || __APPLE__ || HAVE_LIBUSB || HAVE_LINUX_HID)
static void
stub_os_init(const char* fname)
{
  fatal(MYNAME ": OS not supported\n");
}
so it would appear you need libusb or the linux hid interface.

On 7/18/2014 1:24 PM, Ray J 1216 wrote:
Hi:
 
I have a Delorme PN-30 and there may be corruption in the waypoints list or some other problem in the waypoints.  Topo 8 software will no longer access the list and display the contents.  Delorme support was unable to help.
 
I found your software.  Trying to use it to capture as many of my recently added waypoints as possible.  Just downloaded the latest (1.5.1) on my Windows Vista laptop.  When running, here's what happens (both from GUI and command line):
 
gpsbabel -w -i delbin -f usb: -o gpx -F C:/Users/Ray admin/Documents/waypoints20140718.gpx

delbin: OS not supported


Error running gpsbabel: Process exited unsuccessfully with code 1

 

Note:  I tried adding in the debug command and it didn't add anything interesting.

 

I get the same OS not supported message, whether trying for waypoints (the problem area) or tracks or routes, which works fine with Topo 8.  So, I think there's something simple or fundamental that's wrong.  Any ideas?

 

Note:  I've tried various combinations of Topo 8 open or closed and disconnecting other USB devices.  Can't find a combination that  works. 

 

Regards,

 

RayJ



------------------------------------------------------------------------------
Want fast and easy access to all the code in your enterprise? Index and
search up to 200,000 lines of code with a free copy of Black Duck
Code Sight - the same software that powers the world's largest code
search on Ohloh, the Black Duck Open Hub! Try it now.
http://p.sf.net/sfu/bds


_______________________________________________
Gpsbabel-misc mailing list http://www.gpsbabel.org
[hidden email]
To unsubscribe, change list options, or see archives, visit:
https://lists.sourceforge.net/lists/listinfo/gpsbabel-misc


------------------------------------------------------------------------------
Want fast and easy access to all the code in your enterprise? Index and
search up to 200,000 lines of code with a free copy of Black Duck
Code Sight - the same software that powers the world's largest code
search on Ohloh, the Black Duck Open Hub! Try it now.
http://p.sf.net/sfu/bds
_______________________________________________
Gpsbabel-misc mailing list http://www.gpsbabel.org
[hidden email]
To unsubscribe, change list options, or see archives, visit:
https://lists.sourceforge.net/lists/listinfo/gpsbabel-misc
SRE
Reply | Threaded
Open this post in threaded view
|

Re: OS not supported

SRE
On 7/18/2014 1:24 PM, Ray J 1216 wrote:
>Just downloaded the latest (1.5.1) on my Windows Vista laptop.

Ray, did you download the executable or the source?

FWIW, I get the same result using the same command line with nothing
connected to my USB port! Also using Windoze Vista, so posts about
that OS catch my eye.


At 12:41 PM 7/18/2014, tsteven4 wrote:
>The relevant GPSBabel code is
>>#if !(HAVE_WDK || __APPLE__ || HAVE_LIBUSB || HAVE_LINUX_HID)

Steven, that's a build choice and not a runtime test, right?

If so, it would seem the error message should be specific for
each of the four conditions listed to suggest how the user
might fix the problem. Loading a shared lib is not something
most know how to do, and the error message doesn't say that
might or will work.

Is this lib required to use USB with GPSBabel?
  http://sourceforge.net/projects/libusb-win32/
If so, maybe it should just be included in the Win distribution.

Steve


------------------------------------------------------------------------------
Want fast and easy access to all the code in your enterprise? Index and
search up to 200,000 lines of code with a free copy of Black Duck
Code Sight - the same software that powers the world's largest code
search on Ohloh, the Black Duck Open Hub! Try it now.
http://p.sf.net/sfu/bds
_______________________________________________
Gpsbabel-misc mailing list http://www.gpsbabel.org
[hidden email]
To unsubscribe, change list options, or see archives, visit:
https://lists.sourceforge.net/lists/listinfo/gpsbabel-misc
Reply | Threaded
Open this post in threaded view
|

Re: OS not supported

tsteven4-2
SRE is correct, this is a compile time problem.  I thought you were
running some version of linux, but I see you said vista.  I think the
code should have been compiled with WDK, so we shouldn't get this
message.  We may need to see how Robert built the 1.5.1 windows executable.

On 7/18/2014 1:57 PM, SRE wrote:

> On 7/18/2014 1:24 PM, Ray J 1216 wrote:
>> Just downloaded the latest (1.5.1) on my Windows Vista laptop.
> Ray, did you download the executable or the source?
>
> FWIW, I get the same result using the same command line with nothing
> connected to my USB port! Also using Windoze Vista, so posts about
> that OS catch my eye.
>
>
> At 12:41 PM 7/18/2014, tsteven4 wrote:
>> The relevant GPSBabel code is
>>> #if !(HAVE_WDK || __APPLE__ || HAVE_LIBUSB || HAVE_LINUX_HID)
> Steven, that's a build choice and not a runtime test, right?
>
> If so, it would seem the error message should be specific for
> each of the four conditions listed to suggest how the user
> might fix the problem. Loading a shared lib is not something
> most know how to do, and the error message doesn't say that
> might or will work.
>
> Is this lib required to use USB with GPSBabel?
>    http://sourceforge.net/projects/libusb-win32/
> If so, maybe it should just be included in the Win distribution.
>
> Steve
>
>
> ------------------------------------------------------------------------------
> Want fast and easy access to all the code in your enterprise? Index and
> search up to 200,000 lines of code with a free copy of Black Duck
> Code Sight - the same software that powers the world's largest code
> search on Ohloh, the Black Duck Open Hub! Try it now.
> http://p.sf.net/sfu/bds
> _______________________________________________
> Gpsbabel-misc mailing list http://www.gpsbabel.org
> [hidden email]
> To unsubscribe, change list options, or see archives, visit:
> https://lists.sourceforge.net/lists/listinfo/gpsbabel-misc


------------------------------------------------------------------------------
Want fast and easy access to all the code in your enterprise? Index and
search up to 200,000 lines of code with a free copy of Black Duck
Code Sight - the same software that powers the world's largest code
search on Ohloh, the Black Duck Open Hub! Try it now.
http://p.sf.net/sfu/bds
_______________________________________________
Gpsbabel-misc mailing list http://www.gpsbabel.org
[hidden email]
To unsubscribe, change list options, or see archives, visit:
https://lists.sourceforge.net/lists/listinfo/gpsbabel-misc
Reply | Threaded
Open this post in threaded view
|

Re: OS not supported

tsteven4-2
In reply to this post by SRE
This appears to be a bug in our build for windows.

On Centos 6 if we do this
>     CXXFLAGS="-I./mingw/include/ddk" \
>     LDFLAGS="-s" \
>     ./configure  --host=i686-pc-mingw32
then configure should show:
...
> checking for Windows DDK... yes
...

However, if we do:
>     CFLAGS="-I./mingw/include/ddk" \
>     LDFLAGS="-s" \
>     ./configure  --host=i686-pc-ming

then configure should show:
> checking for Windows DDK... no

So we broke our build formula when we switched from C to C++.  I don't
know if the release was built with tools/win-cross-config, but that
script won't work anymore for the same reason.


On 7/18/2014 1:57 PM, SRE wrote:

> On 7/18/2014 1:24 PM, Ray J 1216 wrote:
>> Just downloaded the latest (1.5.1) on my Windows Vista laptop.
> Ray, did you download the executable or the source?
>
> FWIW, I get the same result using the same command line with nothing
> connected to my USB port! Also using Windoze Vista, so posts about
> that OS catch my eye.
>
>
> At 12:41 PM 7/18/2014, tsteven4 wrote:
>> The relevant GPSBabel code is
>>> #if !(HAVE_WDK || __APPLE__ || HAVE_LIBUSB || HAVE_LINUX_HID)
> Steven, that's a build choice and not a runtime test, right?
>
> If so, it would seem the error message should be specific for
> each of the four conditions listed to suggest how the user
> might fix the problem. Loading a shared lib is not something
> most know how to do, and the error message doesn't say that
> might or will work.
>
> Is this lib required to use USB with GPSBabel?
>    http://sourceforge.net/projects/libusb-win32/
> If so, maybe it should just be included in the Win distribution.
>
> Steve
>
>
> ------------------------------------------------------------------------------
> Want fast and easy access to all the code in your enterprise? Index and
> search up to 200,000 lines of code with a free copy of Black Duck
> Code Sight - the same software that powers the world's largest code
> search on Ohloh, the Black Duck Open Hub! Try it now.
> http://p.sf.net/sfu/bds
> _______________________________________________
> Gpsbabel-misc mailing list http://www.gpsbabel.org
> [hidden email]
> To unsubscribe, change list options, or see archives, visit:
> https://lists.sourceforge.net/lists/listinfo/gpsbabel-misc


------------------------------------------------------------------------------
Want fast and easy access to all the code in your enterprise? Index and
search up to 200,000 lines of code with a free copy of Black Duck
Code Sight - the same software that powers the world's largest code
search on Ohloh, the Black Duck Open Hub! Try it now.
http://p.sf.net/sfu/bds
_______________________________________________
Gpsbabel-misc mailing list http://www.gpsbabel.org
[hidden email]
To unsubscribe, change list options, or see archives, visit:
https://lists.sourceforge.net/lists/listinfo/gpsbabel-misc