Building gpsbabel-1.5.4 with Qt4

classic Classic list List threaded Threaded
1 message Options
lj
Reply | Threaded
Open this post in threaded view
|

Building gpsbabel-1.5.4 with Qt4

lj
I realize Qt4 is no longer supported, and Qt-5.2 or higher is required. But my
Linux distribution (Slackware-14.2) has Qt-4.8.7, and I'm not about to try to
upgrade Qt on my own. So I made a few changes and built gpsbabel-1.5.4 with
Qt4. If anyone else is stuck on Qt4 and wants to build the latest gpsbabel,
here is a summary of what I did. (I have a patch file I can post if there is
any interest.)

   Makefile.in : delete geojson.o from the list of ALL_FMTS

   main.cc : remove the check for QT_VERSION >= 5.2.8 (or change it to 4.8.0)

   vecs.cc : remove the declaration and block for geojson format

Then just the usual configure; make. Everything seems to work, although you
lose the new (undocumented?) geojson format.


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Gpsbabel-misc mailing list http://www.gpsbabel.org
[hidden email]
To unsubscribe, change list options, or see archives, visit:
https://lists.sourceforge.net/lists/listinfo/gpsbabel-misc